Backend Localization <= 1.9 - Reflected Cross-Site Scripting

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2012-10013
CVSS 6.1 (Medium)
Publicly Published July 30, 2012
Last Updated May 1, 2023

Description

The Backend Localization plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in versions up to, and including, 1.9. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link

References

Share

Vulnerability Details for Backend Localization

Software Type Plugin
Software Slug kau-boys-backend-localization (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.0, or a newer patched version
Affected Version
  • 1.6.1 - 1.6.1
Patched Version
  • 2.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation