KiviCare – Clinic & Patient Management System (EHR) <= 3.2.0 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-2628
CVSS 6.5 (Medium)
Publicly Published June 5, 2023
Last Updated January 22, 2024
Researcher Erwan LR - WPScan


The KiviCare – Clinic & Patient Management System (EHR) plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.2.0. This is due to missing or incorrect nonce validation. This makes it possible for unauthenticated attackers to perform multiple unauthorized actions (e.g., deleting arbitrary appointments and medical records, or creating and updating users, etc.) via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for KiviCare – Clinic & Patient Management System (EHR)

Software Type Plugin
Software Slug kivicare-clinic-management-system (view on
Patched? Yes
Remediation Update to version 3.2.1, or a newer patched version
Affected Version
  • <= 3.2.0
Patched Version
  • 3.2.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.