LayerSlider <= 7.1.1 - Admin+ Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-1153
CVSS 5.5 (Medium)
Publicly Published April 11, 2022
Last Updated July 8, 2022
Researcher Taurus Omar


The LayerSlider WordPress plugin before 7.1.2 does not sanitise and escape Project's slug before outputting it back in various place, which could allow high privilege users such as admin to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed



1 affected software package

Software Type Plugin
Software Slug layerslider
Patched? Yes
Remediation Update to version 7.1.2, or a newer patched version
Affected Version
  • <= 7.1.1
Patched Version
  • 7.1.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.