Active Directory Integration / LDAP Integration <= 4.1.5 - Authenticated (Subscriber+) LDAP Injection

Improper Neutralization of Special Elements used in an LDAP Query ('LDAP Injection')
CVE CVE-2023-3447
CVSS 7.6 (High)
Publicly Published June 28, 2023
Last Updated August 9, 2023
Researchers Luca Greeb
Andreas Krüger


The Active Directory Integration / LDAP Integration plugin for WordPress is vulnerable to LDAP Injection in versions up to, and including, 4.1.5. This is due to insufficient escaping on the supplied username value. This makes it possible for attackers, with an existing account on a vulnerable WordPress instance, to extract potentially sensitive information from the LDAP directory.



1 affected software package

Software Type Plugin
Software Slug ldap-login-for-intranet-sites (view on
Patched? Yes
Remediation Update to version 4.1.6, or a newer patched version
Affected Version
  • <= 4.1.5
Patched Version
  • 4.1.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.