Contact Form & Lead Form Elementor Builder <= 1.6.3 - Unauthenticated Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24967
CVSS 7.2 (High)
Publicly Published November 29, 2021
Last Updated December 5, 2022
Researcher Krzysztof Zając - CERT PL


The Contact Form & Lead Form Elementor Builder WordPress plugin before 1.6.4 does not sanitise and escape some lead values, which could allow unauthenticated users to perform Cross-Site Scripting attacks against logged in admin viewing the inserted Leads



Vulnerability Details for Responsive Contact Form Builder & Lead Generation Plugin

Software Type Plugin
Software Slug lead-form-builder (view on
Patched? Yes
Remediation Update to version 1.6.4, or a newer patched version
Affected Version
  • <= 1.6.3
Patched Version
  • 1.6.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.