Responsive Contact Form Builder & Lead Generation Plugin <= 1.8.9 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-1415
CVSS 4.3 (Medium)
Publicly Published April 11, 2024
Last Updated May 21, 2024
Researcher Duc Manh


The Responsive Contact Form Builder & Lead Generation Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.8.9. This is due to missing or incorrect nonce validation on several functions. This makes it possible for unauthenticated attackers to invoke those functions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. These actions may result in form deletion, and lead signup as well as file upload.



Vulnerability Details for Responsive Contact Form Builder & Lead Generation Plugin

Software Type Plugin
Software Slug lead-form-builder (view on
Patched? Yes
Remediation Update to version 1.9.0, or a newer patched version
Affected Version
  • <= 1.8.9
Patched Version
  • 1.9.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.