Responsive Contact Form Builder & Lead Generation Plugin <= 1.9.1 - Authenticated (Subscriber+) Arbitrary Shortcode Execution

Improper Control of Generation of Code ('Code Injection')
CVE CVE-2024-4261
CVSS 5.4 (Medium)
Publicly Published May 21, 2024
Last Updated May 22, 2024
Researcher stealthcopter


The Responsive Contact Form Builder & Lead Generation Plugin plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 1.9.1. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for authenticated attackers, with subscriber-level access and above, to execute arbitrary shortcodes.



Vulnerability Details for Responsive Contact Form Builder & Lead Generation Plugin

Software Type Plugin
Software Slug lead-form-builder (view on
Patched? Yes
Remediation Update to version 1.9.2, or a newer patched version
Affected Version
  • <= 1.9.1
Patched Version
  • 1.9.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.