Leaflet Map <= 2.23.3 - Contributor+ Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24468
CVSS 6.4 (Medium)
Publicly Published July 1, 2021
Last Updated December 30, 2022
Researcher apple502j


The Leaflet Map WordPress plugin before 3.0.0 does not escape some shortcode attributes before they are used in JavaScript code or HTML, which could allow users with a role as low as Contributors to exploit stored XSS issues



1 affected software package

Software Type Plugin
Software Slug leaflet-map (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.0.0, or a newer patched version
Affected Version
  • <= 2.23.3
Patched Version
  • 3.0.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.