Leaky Paywall <= 4.20.8 - Missing Authorization to Price Manipulation

External Control of Assumed-Immutable Web Parameter
CVE CVE-2024-33594
CVSS 5.3 (Medium)
Publicly Published April 25, 2024
Last Updated May 1, 2024
Researcher Joshua Chan


The Leaky Paywall plugin for WordPress is vulnerable to price manipulation in all versions up to, and including, 4.20.8. This is due to the plugin allowing the price field to be user supplied. This makes it possible for unauthenticated attackers to alter the price of memberships.



Vulnerability Details for Leaky Paywall

Software Type Plugin
Software Slug leaky-paywall (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.20.9, or a newer patched version
Affected Version
  • <= 4.20.8
Patched Version
  • 4.20.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.