Masteriyo - LMS <= 1.7.2 - Unauthenticated Privilege Escalation

Missing Authorization
CVE CVE-2024-24882
CVSS 9.8 (Critical)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Steven Julian


The Masteriyo LMS – eLearning and Online Course Builder for WordPress plugin for WordPress is vulnerable to privilege escalation due to a missing capability check on the update_logged_in_user() function in all versions up to, and including, 1.7.2. This makes it possible for unauthenticated attackers to elevate their privileges to that of an administrator.



Vulnerability Details for Masteriyo LMS – eLearning and Online Course Builder for WordPress

Software Type Plugin
Software Slug learning-management-system (view on
Patched? Yes
Remediation Update to version 1.7.3, or a newer patched version
Affected Version
  • <= 1.7.2
Patched Version
  • 1.7.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.