LearnPress <= 4.1.7.3.2 - Unauthenticated Local File Inclusion

9.8
Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2022-47615
CVSS 9.8 (Critical)
Publicly Published January 20, 2023
Last Updated January 22, 2024
Researcher Rafie Muhammad - Patchstack

Description

The LearnPress plugin for WordPress is vulnerable to Local File Inclusion in versions up to, and including, 4.1.7.3.2 via the lp/v1/courses/archive-course rest API endpoint. This allows unauthenticated-level attackers to include and execute arbitrary files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where images and other “safe” file types can be uploaded and included.

Wordfence blocked 1 attacks targeting this vulnerability in the past 24 hours.

References

Share

Vulnerability Details for LearnPress – WordPress LMS Plugin

Software Type Plugin
Software Slug learnpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.2.0, or a newer patched version
Affected Version
  • <= 4.1.7.3.2
Patched Version
  • 4.2.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation