LearnPress – WordPress LMS Plugin <= 4.0.0 - Cross-Site Request Forgery to Privilege Escalation

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-2115
CVSS 8.8 (High)
Publicly Published April 4, 2024
Last Updated April 5, 2024
Researcher Tim Coen


The LearnPress – WordPress LMS Plugin plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 4.0.0. This is due to missing or incorrect nonce validation on the filter_users functions. This makes it possible for unauthenticated attackers to elevate their privileges to that of a teacher via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for LearnPress – WordPress LMS Plugin

Software Type Plugin
Software Slug learnpress (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.1, or a newer patched version
Affected Version
  • <= 4.0.0
Patched Version
  • 4.0.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.