LetsRecover <= 1.1.0 - Authenticated (Admin+) SQL Injection

7.2
Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection')
CVE CVE-2022-4355
CVSS 7.2 (High)
Publicly Published December 9, 2022
Last Updated May 19, 2023
Researchers Daniel Krohmer
Kunal Sharma

Description

The LetsRecover plugin for WordPress is vulnerable to generic SQL Injection via an unspecified parameter in versions up to, and including, 1.1.0 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for administrator-level attackers to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

References

Share

1 affected software package

Software Type Plugin
Software Slug letsrecover-woocommerce-abandoned-cart (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.0, or a newer patched version
Affected Version
  • <= 1.1.0
Patched Version
  • 1.2.0

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation