LifterLMS <= 7.4.2 - Authenticated(Administrator+) Directory Traversal to Arbitrary CSV File Deletion

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal')
CVE CVE-2023-6160
CVSS 3.3 (Low)
Publicly Published November 5, 2023
Last Updated November 22, 2023
Researcher Hüseyin TINTAŞ


The LifterLMS – WordPress LMS Plugin for eLearning plugin for WordPress is vulnerable to Directory Traversal in versions up to, and including, 7.4.2 via the maybe_serve_export function. This makes it possible for authenticated attackers, with administrator or LMS manager access and above, to read the contents of arbitrary CSV files on the server, which can contain sensitive information as well as removing those files from the server.



Vulnerability Details for LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes

Software Type Plugin
Software Slug lifterlms (view on
Patched? Yes
Remediation Update to version 7.5.0, or a newer patched version
Affected Version
  • <= 7.4.2
Patched Version
  • 7.5.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.