LifterLMS – WordPress LMS Plugin for eLearning <= 7.5.1 - Missing Authorization via process_review

5.3
Improper Access Control
CVE CVE-2024-0377
CVSS 5.3 (Medium)
Publicly Published February 27, 2024
Last Updated March 13, 2024
Researcher Francesco Carlucci

Description

The LifterLMS – WordPress LMS Plugin for eLearning plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the 'process_review' function in all versions up to, and including, 7.5.1. This makes it possible for unauthenticated attackers to publish an unrestricted number of reviews on the site.

References

Share

Vulnerability Details for LifterLMS – WordPress LMS Plugin for eLearning

Software Type Plugin
Software Slug lifterlms (view on wordpress.org)
Patched? Yes
Remediation Update to version 7.5.2, or a newer patched version
Affected Version
  • <= 7.5.1
Patched Version
  • 7.5.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation