Limit Login Attempts <= 1.7.1 - Authenticated(Subscriber+) Stored Cross-Site Scripting

6.4
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-1861
CVSS 6.4 (Medium)
Publicly Published April 10, 2023
Last Updated April 14, 2023
Researcher Marc-Alexandre Montpas

Description

The Limit Login Attempts plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 1.7.1 due to insufficient input sanitization and output escaping when displaying usernames on the log page. This makes it possible for authenticated attackers with subscriber-level permissions or above to inject arbitrary web scripts in pages that will execute whenever an administrator accesses the plugin's settings page.

References

Share

1 affected software package

Software Type Plugin
Software Slug limit-login-attempts (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.7.2, or a newer patched version
Affected Version
  • <= 1.7.1
Patched Version
  • 1.7.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation