LiteSpeed Cache <= 4.4.3 - Authorization Bypass

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24964
CVSS 6.5 (Medium)
Publicly Published November 30, 2021
Last Updated January 10, 2023
Researcher Emil Kylander


The LiteSpeed Cache WordPress plugin before 4.4.4 does not properly verify that requests are coming from servers, allowing attackers to make requests to certain endpoints by using a specific X-Forwarded-For header value. In addition, one of the endpoint could be used to set CSS code if a setting is enabled, which will then be output in some pages without being sanitised and escaped. Combining those two issues, an unauthenticated attacker could put Cross-Site Scripting payloads in pages visited by users.



Vulnerability Details for LiteSpeed Cache

Software Type Plugin
Software Slug litespeed-cache (view on
Patched? Yes
Remediation Update to version 4.4.4, or a newer patched version
Affected Version
  • 1.0.15 - 4.4.3
Patched Version
  • 4.4.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.