LiteSpeed Cache <= 4.4.3 - Reflected Cross-Site Scripting via qc_res

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2021-24963
CVSS 6.1 (Medium)
Publicly Published November 30, 2021
Last Updated January 10, 2023
Researcher Emil Kylander


The LiteSpeed Cache plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'qc_res' parameter in versions up to, and including, 4.4.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.



Vulnerability Details for LiteSpeed Cache

Software Type Plugin
Software Slug litespeed-cache (view on
Patched? Yes
Remediation Update to version 4.4.4, or a newer patched version
Affected Version
  • 1.0.15 - 4.4.3
Patched Version
  • 4.4.4

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.