Page Builder: Live Composer <= 1.5.38 - Missing Authorization

Missing Authorization
CVE CVE-2024-32957
CVSS 4.3 (Medium)
Publicly Published April 23, 2024
Last Updated April 29, 2024
Researcher Phill Sav (Savphill)


The Page Builder: Live Composer plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the dslc_ajax_add_module() function in versions up to, and including, 1.5.38. This makes it possible for authenticated attackers, with author-level access and above, to add modules.



Vulnerability Details for Live Composer – Free WordPress Website Builder

Software Type Plugin
Software Slug live-composer-page-builder (view on
Patched? Yes
Remediation Update to version 1.5.39, or a newer patched version
Affected Version
  • <= 1.5.38
Patched Version
  • 1.5.39

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.