LiveChat Elementor <= 1.0.13 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published January 8, 2024
Last Updated January 22, 2024


The WordPress Live Chat Plugin for Elementor – LiveChat plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.0.13. This is due to missing or incorrect nonce validation via several functions in the plugin_files/Services/SettingsProvider.class.php file. This makes it possible for unauthenticated attackers to perform unauthorized actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for WordPress Live Chat Plugin for Elementor – LiveChat

Software Type Plugin
Software Slug livechat-elementor (view on
Patched? Yes
Remediation Update to version 1.0.14, or a newer patched version
Affected Version
  • <= 1.0.13
Patched Version
  • 1.0.14

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.