Login as User or Customer <= 3.2 - Privilege Escalation

9.8
Improper Authorization
CVE CVE-2022-4305
CVSS 9.8 (Critical)
Publicly Published December 27, 2022
Last Updated April 6, 2023
Researcher cydave

Description

The Login as User or Customer plugin for WordPress is vulnerable to authorization bypass due to improper authorization checks on the loginas_return_admin() function in versions up to, and including, 3.2. This makes it possible for unauthenticated attackers to log in as administrators on the vulnerable site. A similar vulnerability is present in the my_action function which allows subscriber-level users and higher to log in as administrators.

References

Share

1 affected software package

Software Type Plugin
Software Slug login-as-customer-or-user (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.3, or a newer patched version
Affected Version
  • <= 3.2
Patched Version
  • 3.3

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation