Login Lockdown – Protect Login Form <= 2.08 - Missing Authorization

5.4
Missing Authorization
CVE CVE-2024-1340
CVSS 5.4 (Medium)
Publicly Published February 9, 2024
Last Updated February 20, 2024
Researcher Lucio Sá

Description

The Login Lockdown – Protect Login Form plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the generate_export_file function in all versions up to, and including, 2.08. This makes it possible for authenticated attackers, with subscriber access and higher, to export this plugin's settings that include whitelisted IP addresses as well as a global unlock key. With the global unlock key an attacker can add their IP address to the whitelist.

References

Share

Vulnerability Details for Login Lockdown – Protect Login Form

Software Type Plugin
Software Slug login-lockdown (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.09, or a newer patched version
Affected Version
  • <= 2.08
Patched Version
  • 2.09

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation