Logo Slider <= 3.5.3 - Authenticated (Contributor+) Stored Cross-Site Scripting

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2022-4664
CVSS 6.4 (Medium)
Publicly Published December 16, 2022
Last Updated January 13, 2023
Researcher István Márton - Wordfence


The Logo Slider plugin for WordPress is vulnerable to Stored Cross-Site Scripting via numerous shortcodes in versions up to, and including, 3.5.3 due to insufficient input sanitization and output escaping in the 'lgx_output_function_dep' function. This makes it possible for contributor-level attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Logo Slider – Logo Carousel, Logo Showcase & Client Logo Slider WordPress Plugin

Software Type Plugin
Software Slug logo-slider-wp (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.6.0, or a newer patched version
Affected Version
  • <= 3.5.3
Patched Version
  • 3.6.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.