LWS Hide Login <= 2.1.6 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-34025
CVSS 4.3 (Medium)
Publicly Published May 31, 2023
Last Updated June 19, 2023
Researcher konagash


The LWS Hide Login plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.1.6. This is due to missing nonce validation on several of its functions such as lws_hl_create_page() and lws_hl_create_page_network(). This makes it possible for unauthenticated attackers to invoke this function and create plugin setting pages via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug lws-hide-login (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.1.7, or a newer patched version
Affected Version
  • <= 2.1.6
Patched Version
  • 2.1.7

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.