Shoppable Images <= 1.2.3 - Cross Site Request Forgery

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-25698
CVSS 5.4 (Medium)
Publicly Published February 13, 2023
Last Updated February 17, 2023
Researcher Rio Darmawan


The Shoppable Images plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.2.3. This is due to missing or incorrect nonce validation on several functions used to manipulate images. This makes it possible for unauthenticated attackers to perform image manipulation tasks such as deletion, and delete arbitrary posts, granted they can trick a site administrator into performing an action such as clicking on a link.



1 affected software package

Software Type Plugin
Software Slug mabel-shoppable-images-lite (view on
Patched? Yes
Remediation Update to version 1.2.4, or a newer patched version
Affected Version
  • <= 1.2.3
Patched Version
  • 1.2.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.