Marker.io <= 1.1.6 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVSS 4.3 (Medium)
Publicly Published October 3, 2023
Last Updated January 22, 2024

Description

The Marker.io plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.1.6. This is due to missing nonce validation on the markerio_save_destination() and markerio_save_option() functions. This makes it possible for unauthenticated attackers to modify the plugins settings and save destinations via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug marker-io (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.1.7, or a newer patched version
Affected Version
  • < 1.1.7
Patched Version
  • 1.1.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation