MasterStudy LMS <= 3.0.17 - Privilege Escalation

Improper Privilege Management
CVE CVE-2023-4278
CVSS 7.3 (High)
Publicly Published August 21, 2023
Last Updated January 22, 2024
Researcher Revan Arifio


The MasterStudy LMS plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 3.0.17. This makes it possible for unauthenticated attackers to register on the site as instructors, which would enable them to create courses.



Vulnerability Details for MasterStudy LMS WordPress Plugin – for Online Courses and Education

Software Type Plugin
Software Slug masterstudy-lms-learning-management-system (view on
Patched? Yes
Remediation Update to version 3.0.18, or a newer patched version
Affected Version
  • <= 3.0.17
Patched Version
  • 3.0.18

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.