MasterStudy LMS <= 3.2.13 - Missing Authorization to Sensitive Information Exposure in search_posts

Missing Authorization
CVE CVE-2024-1904
CVSS 4.3 (Medium)
Publicly Published March 15, 2024
Last Updated April 9, 2024
Researcher Krzysztof Zając - CERT PL


The MasterStudy LMS plugin for WordPress is vulnerable to unauthorized access of data due to a missing capability check on the search_posts function in all versions up to, and including, 3.2.13. This makes it possible for authenticated attackers, with subscriber-level access and above, to expose draft post titles and excerpts.



Vulnerability Details for MasterStudy LMS WordPress Plugin – for Online Courses and Education

Software Type Plugin
Software Slug masterstudy-lms-learning-management-system (view on
Patched? Yes
Remediation Update to version 3.3.0, or a newer patched version
Affected Version
  • <= 3.2.13
Patched Version
  • 3.3.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.