MasterStudy LMS <= 3.3.1 - Unauthenticated Privilege Escalation via stm_lms_register AJAX Action

Incorrect Privilege Assignment
CVE CVE-2024-2409
CVSS 9.8 (Critical)
Publicly Published March 28, 2024
Last Updated March 29, 2024
Researcher Hiroho Shimada


The MasterStudy LMS plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 3.3.1. This is due to insufficient validation checks within the _register_user() function called by the 'wp_ajax_nopriv_stm_lms_register' AJAX action. This makes it possible for unauthenticated attackers to register a user with administrator-level privileges when MasterStudy LMS Pro is installed and the LMS Forms Editor add-on is enabled.



Vulnerability Details for MasterStudy LMS WordPress Plugin – for Online Courses and Education

Software Type Plugin
Software Slug masterstudy-lms-learning-management-system (view on
Patched? Yes
Remediation Update to version 3.3.2, or a newer patched version
Affected Version
  • <= 3.3.1
Patched Version
  • 3.3.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.