Mesmerize Companion <= 1.6.148 - Authenticated (Contributor+) Stored Cross-Site Scripting via mesmerize_contact_form Shortcode

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-3494
CVSS 6.4 (Medium)
Publicly Published May 7, 2024
Last Updated May 8, 2024
Researcher stealthcopter


The Mesmerize Companion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'mesmerize_contact_form' shortcode in all versions up to, and including, 1.6.148 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for Mesmerize Companion

Software Type Plugin
Software Slug mesmerize-companion (view on
Patched? Yes
Remediation Update to version 1.6.149, or a newer patched version
Affected Version
  • <= 1.6.148
Patched Version
  • 1.6.149

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.