Metform Elementor Contact Form Builder <= 2.1.3 - Sensitive Information Disclosure

Missing Authorization
CVE CVE-2022-1442
CVSS 7.5 (High)
Publicly Published April 23, 2022
Last Updated January 10, 2023
Researcher Muhammad Zeeshan (Xib3rR4dAr)


The Metform WordPress plugin is vulnerable to sensitive information disclosure due to improper access control in the ~/core/forms/action.php file which can be exploited by an unauthenticated attacker to view all API keys and secrets of integrated third-party APIs like that of PayPal, Stripe, Mailchimp, Hubspot, HelpScout, reCAPTCHA and many more, in versions up to and including 2.1.3.



1 affected software package

Software Type Plugin
Software Slug metform (view on
Patched? Yes
Remediation Update to version 2.1.4, or a newer patched version
Affected Version
  • <= 2.1.3
Patched Version
  • 2.1.4

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.