Metform Elementor Contact Form Builder <= 3.3.2 - Cross-Site Request Forgery via permalink_setup

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-2517
CVSS 5.4 (Medium)
Publicly Published June 22, 2023
Last Updated January 22, 2024
Researcher Marco Wotschka - Wordfence


The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.3.2. This is due to missing or incorrect nonce validation on the permalink_setup function. This makes it possible for unauthenticated attackers to change the permalink structure via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. While nonce verification is implemented, verification only takes place when a nonce is provided.



Vulnerability Details for MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor

Software Type Plugin
Software Slug metform (view on
Patched? Yes
Remediation Update to version 3.3.3, or a newer patched version
Affected Version
  • <= 3.3.2
Patched Version
  • 3.3.3

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.