Metform Elementor Contact Form Builder <= 3.8.1 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-6788
CVSS 5.4 (Medium)
Publicly Published January 8, 2024
Last Updated January 22, 2024
Researcher Lucio Sá


The Metform Elementor Contact Form Builder plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 3.8.1. This is due to missing or incorrect nonce validation on the contents function. This makes it possible for unauthenticated attackers to update the options "mf_hubsopt_token", "mf_hubsopt_refresh_token", "mf_hubsopt_token_type", and "mf_hubsopt_expires_in" via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. This would allow an attacker to connect their own Hubspot account to a victim site's metform to obtain leads and contacts.



Vulnerability Details for MetForm – Contact Form, Survey, Quiz, & Custom Form Builder for Elementor

Software Type Plugin
Software Slug metform (view on
Patched? Yes
Remediation Update to version 3.8.2, or a newer patched version
Affected Version
  • <= 3.8.1
Patched Version
  • 3.8.2

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.