miniOrange's Google Authenticator <= 5.6.1 - Missing Authorization to Plugin Settings Change

Missing Authorization
CVE CVE-2022-42461
CVSS 5.4 (Medium)
Publicly Published October 31, 2022
Last Updated January 2, 2023
Researcher Lana Codes


The miniOrange's Google Authenticator plugin for WordPress is vulnerable to authorization bypass due to a missing capability check when changing plugin settings in versions up to, and including, 5.6.1. This makes it possible for authenticated attackers, with subscriber-level permissions and above, to change the plugin's settings.



1 affected software package

Software Type Plugin
Software Slug miniorange-2-factor-authentication (view on
Patched? Yes
Remediation Update to version 5.6.2, or a newer patched version
Affected Version
  • <= 5.6.1
Patched Version
  • 5.6.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.