miniOrange's Google Authenticator <= 5.6.5 - Missing Authorization to Plugin Settings Change

Missing Authorization
CVE CVE-2022-4943
CVSS 7.5 (High)
Publicly Published April 19, 2023
Last Updated October 20, 2023
Researcher Ram - Wordfence


The miniOrange's Google Authenticator plugin for WordPress is vulnerable to authorization bypass due to a missing capability check when changing plugin settings in versions up to, and including, 5.6.5. This makes it possible for unauthenticated attackers to change the plugin's settings.



1 affected software package

Software Type Plugin
Software Slug miniorange-2-factor-authentication (view on
Patched? Yes
Remediation Update to version 5.6.6, or a newer patched version
Affected Version
  • <= 5.6.5
Patched Version
  • 5.6.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.