Modern Events Calendar Lite <= 5.1.6 - Missing Authorization to Stored Cross-Site Scripting and Settings Update

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2020-9459
CVSS 5.4 (Medium)
Publicly Published February 27, 2020
Last Updated November 29, 2022
Researchers Sean Murphy
Ramuel Gall - Wordfence
Matt Rusnak


Multiple Stored Cross-site scripting (XSS) vulnerabilities in the Webnus Modern Events Calendar Lite plugin through 5.1.6 for WordPress allows remote authenticated users (with minimal permissions) to inject arbitrary JavaScript, HTML, or CSS via Ajax actions. This affects mec_save_notifications and import_settings.



1 affected software package

Software Type Plugin
Software Slug modern-events-calendar-lite (view on
Patched? Yes
Remediation Update to version 5.1.7, or a newer patched version
Affected Version
  • < 5.1.7
Patched Version
  • 5.1.7

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.