Modula <= 2.7.4 - Incomplete Authorization via 'save_image' and 'save_images'

Improper Authorization
CVSS 2.2 (Low)
Publicly Published September 10, 2023
Last Updated September 11, 2023


The Modula plugin for WordPress is vulnerable to unauthorized modification of data due to an incomplete capability check on the 'save_image' and 'save_images' functions in versions up to, and including, 2.7.4. This makes it possible for authenticated attackers with the 'edit_others_posts' but not the 'edit_posts' capability to save images. Note that this would only be considered a vulnerability on extremely unusual configurations.



1 affected software package

Software Type Plugin
Software Slug modula-best-grid-gallery (view on
Patched? Yes
Remediation Update to version 2.7.5, or a newer patched version
Affected Version
  • < 2.7.5
Patched Version
  • 2.7.5

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.