MStore API <= 2.1.5 - Authentication Bypass

Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2020-36713
CVSS 9.8 (Critical)
Publicly Published March 11, 2020
Last Updated June 7, 2023
Researcher Jerome Bruandet - NinTechNet


The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 2.1.5. This is due to unrestricted access to the 'register' and 'update_user_profile' routes. This makes it possible for unauthenticated attackers to create new administrator accounts, delete existing administrator accounts, or escalate privileges on any account.



1 affected software package

Software Type Plugin
Software Slug mstore-api (view on
Patched? Yes
Remediation Update to version 2.1.6, or a newer patched version
Affected Version
  • < 2.1.6
Patched Version
  • 2.1.6

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.