MStore API <= 3.9.0 - Authentication Bypass

9.8
Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2023-2733
CVSS 9.8 (Critical)
Publicly Published May 17, 2023
Last Updated January 22, 2024
Researcher István Márton - Wordfence

Description

The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.9.0. This is due to insufficient verification on the user being supplied during the coupon redemption REST API request through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the user id.

Wordfence blocked 3 attacks targeting this vulnerability in the past 24 hours.

References

Share

1 affected software package

Software Type Plugin
Software Slug mstore-api (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.9.1, or a newer patched version
Affected Version
  • <= 3.9.0
Patched Version
  • 3.9.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation