MStore API <= 3.9.1 - Authentication Bypass

Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2023-2734
CVSS 9.8 (Critical)
Publicly Published May 22, 2023
Last Updated May 25, 2023
Researcher Lana Codes - Wordfence


The MStore API plugin for WordPress is vulnerable to authentication bypass in versions up to, and including, 3.9.1. This is due to insufficient verification on the user being supplied during the cart sync from mobile REST API request through the plugin. This makes it possible for unauthenticated attackers to log in as any existing user on the site, such as an administrator, if they have access to the user id.

Wordfence blocked 846 attacks targeting this vulnerability in the past 24 hours.



1 affected software package

Software Type Plugin
Software Slug mstore-api (view on
Patched? Yes
Remediation Update to version 3.9.2, or a newer patched version
Affected Version
  • <= 3.9.1
Patched Version
  • 3.9.2

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.