MStore API <= 3.9.6 - Missing Authorization

Missing Authorization
CVE CVE-2023-3131
CVSS 6.5 (Medium)
Publicly Published June 12, 2023
Last Updated June 23, 2023
Researcher Truoc Phan


The MStore API plugin for WordPress is vulnerable to unauthorized modification of data due to missing capability checks on several functions called via AJAX actions such as mstore_delete_json_file, mstore_update_limit_product, mstore_update_firebase_server_key, mstore_update_new_order_title, mstore_update_new_order_message, mstore_update_status_order_title, and mstore_update_status_order_message in versions up to, and including, 3.9.6. This makes it possible for authenticated attackers with minimal permissions, such as a subscriber, to perform several unauthorized actions that allow the attacker to control the plugins settings. This was partially patched in 3.9.6 but not fully patched until 3.9.7. CVE-2023-3209 Also applies to this vulnerability.



Vulnerability Details for MStore API – Create Native Android & iOS Apps On The Cloud

Software Type Plugin
Software Slug mstore-api (view on
Patched? Yes
Remediation Update to version 3.9.7, or a newer patched version
Affected Version
  • < 3.9.7
Patched Version
  • 3.9.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.