MStore API <= 3.9.6 - Cross-Site Request Forgery to Order Status Update

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-3198
CVSS 4.3 (Medium)
Publicly Published June 13, 2023
Last Updated January 22, 2024
Researcher Truoc Phan


The MStore API plugin for WordPress is vulnerable to Cross-Site Request Forgery due to missing nonce validation on the mstore_update_status_order_message function. This makes it possible for unauthenticated attackers to update status order message via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for MStore API – Create Native Android & iOS Apps On The Cloud

Software Type Plugin
Software Slug mstore-api (view on
Patched? Yes
Remediation Update to version 3.9.7, or a newer patched version
Affected Version
  • <= 3.9.6
Patched Version
  • 3.9.7

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.