MStore API <= 3.9.8 - Unauthenticated Privilege Escalation

Incorrect Privilege Assignment
CVE CVE-2023-3076
CVSS 9.8 (Critical)
Publicly Published June 19, 2023
Last Updated June 23, 2023
Researcher Truoc Phan


The MStore API plugin for WordPress is vulnerable to Privilege Escalation in versions up to, and including, 3.9.8 due to insufficient restriction on roles supplied during registration through the /register REST route. This allows unauthenticated attackers register as administrators.



Vulnerability Details for MStore API – Create Native Android & iOS Apps On The Cloud

Software Type Plugin
Software Slug mstore-api (view on
Patched? Yes
Remediation Update to version 3.9.9, or a newer patched version
Affected Version
  • <= 3.9.8
Patched Version
  • 3.9.9

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.