MStore API <= 4.10.7 - Unauthorized Account Access and Privilege Escalation

9.8
Authentication Bypass Using an Alternate Path or Channel
CVE CVE-2023-3277
CVSS 9.8 (Critical)
Publicly Published June 19, 2023
Last Updated January 22, 2024
Researchers Truoc Phan
An Đặng

Description

The MStore API plugin for WordPress is vulnerable to Unauthorized Account Access and Privilege Escalation in versions up to, and including, 4.10.7 due to improper implementation of the Apple login feature. This allows unauthenticated attackers to log in as any user as long as they know the user's email address.

Wordfence blocked 13 attacks targeting this vulnerability in the past 24 hours.

References

Share

1 affected software package

Software Type Plugin
Software Slug mstore-api (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.10.8, or a newer patched version
Affected Version
  • <= 4.10.7
Patched Version
  • 4.10.8

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation