Multiple Page Generator Plugin <= 3.3.17 - Cross-Site Request Forgery to SQL Injection

Cross-Site Request Forgery (CSRF)
CVE CVE-2023-2608
CVSS 3.1 (Low)
Publicly Published May 16, 2023
Last Updated January 22, 2024
Researcher Marco Wotschka - Wordfence


The Multiple Page Generator Plugin for WordPress is vulnerable to Cross-Site Request Forgery leading to time-based SQL Injection via the orderby and order parameters in versions up to, and including, 3.3.17 due to missing nonce verification on the projects_list function and insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for unauthenticated attackers to append additional SQL queries into already existing queries leading to resource exhaustion via a forged request granted they can trick an administrator into performing an action such as clicking on a link. Version 3.3.18 addresses the SQL Injection, which drastically reduced the severity.



Vulnerability Details for Multiple Page Generator Plugin – MPG

Software Type Plugin
Software Slug multiple-pages-generator-by-porthas (view on
Patched? Yes
Remediation Update to version 3.3.18, or a newer patched version
Affected Version
  • <= 3.3.17
Patched Version
  • 3.3.18

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.