Multiple Page Generator Plugin – MPG <= 3.4.0 - Cross-Site Request Forgery

Cross-Site Request Forgery (CSRF)
CVE CVE-2024-31301
CVSS 4.3 (Medium)
Publicly Published April 5, 2024
Last Updated April 11, 2024
Researcher Majed Refaea


The Multiple Page Generator Plugin – MPG plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.4.0. This is due to missing or incorrect nonce validation on the delete_project action. This makes it possible for unauthenticated attackers to delete projects via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.



Vulnerability Details for Multiple Page Generator Plugin – MPG

Software Type Plugin
Software Slug multiple-pages-generator-by-porthas (view on
Patched? Yes
Remediation Update to version 3.4.1, or a newer patched version
Affected Version
  • <= 3.4.0
Patched Version
  • 3.4.1

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.