Multiple Wow-Company Plugins (Various Versions) -- Reflected Cross-Site Scripting via 'page' parameter

6.1
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2023-2362
CVSS 6.1 (Medium)
Publicly Published May 22, 2023
Last Updated January 22, 2024
Researcher Erwan LR - WPScan

Description

Several plugins by Wow-Company are vulnerable to Reflected Cross-Site Scripting via the ‘page’ parameter in various versions due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Share

Vulnerability Details for Herd Effects – fake notifications and social proof plugin

Software Type Plugin
Software Slug mwp-herd-effect (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.2.2, or a newer patched version
Affected Version
  • <= 5.2.1
Patched Version
  • 5.2.2

11 other affected software packages

Software Type Plugin
Software Slug bubble-menu (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.0.4, or a newer patched version
Affected Version
  • <= 3.0.3
Patched Version
  • 3.0.4
Software Type Plugin
Software Slug button-generation (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.3.5, or a newer patched version
Affected Version
  • <= 2.3.4
Patched Version
  • 2.3.5
Software Type Plugin
Software Slug calculator-builder (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.5.1, or a newer patched version
Affected Version
  • <= 1.5.0
Patched Version
  • 1.5.1
Software Type Plugin
Software Slug counter-box (view on wordpress.org)
Patched? Yes
Remediation Update to version 1.2.2, or a newer patched version
Affected Version
  • <= 1.2.1
Patched Version
  • 1.2.2
Software Type Plugin
Software Slug float-menu (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.0.2, or a newer patched version
Affected Version
  • <= 5.0.1
Patched Version
  • 5.0.2
Software Type Plugin
Software Slug profit-button (view on wordpress.org)
Patched? Yes
Remediation Update to version 5.3.1, or a newer patched version
Affected Version
  • <= 5.3.0
Patched Version
  • 5.3.1
Software Type Plugin
Software Slug popup-box (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.2.2, or a newer patched version
Affected Version
  • <= 2.2.1
Patched Version
  • 2.2.2
Software Type Plugin
Software Slug side-menu-lite (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.2, or a newer patched version
Affected Version
  • <= 4.0.1
Patched Version
  • 4.0.2
Software Type Plugin
Software Slug sticky-buttons (view on wordpress.org)
Patched? Yes
Remediation Update to version 3.1.1, or a newer patched version
Affected Version
  • <= 3.1.0
Patched Version
  • 3.1.1
Software Type Plugin
Software Slug mwp-skype (view on wordpress.org)
Patched? Yes
Remediation Update to version 4.0.2, or a newer patched version
Affected Version
  • <= 4.0.1
Patched Version
  • 4.0.2
Software Type Plugin
Software Slug wp-coder (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.5.6, or a newer patched version
Affected Version
  • <= 2.5.5
Patched Version
  • 2.5.6

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation