My Calendar <= 3.4.23 - Authenticated (Admin+) Stored Cross-Site Scripting via Events

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
CVE CVE-2024-1274
CVSS 4.4 (Medium)
Publicly Published February 11, 2024
Last Updated April 24, 2024
Researcher cyc707


The My Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting via events in all versions up to, and including, 3.4.23 due to insufficient input sanitization and output escaping on event dates. This makes it possible for authenticated attackers with, admin-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.



Vulnerability Details for My Calendar – Accessible Event Manager

Software Type Plugin
Software Slug my-calendar (view on
Patched? Yes
Remediation Update to version 3.4.24, or a newer patched version
Affected Version
  • <= 3.4.23
Patched Version
  • 3.4.24

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.