MyCryptoCheckout <= 2.125 - Cross-Site Request Forgery

4.3
Cross-Site Request Forgery (CSRF)
CVE CVE-2023-41693
CVSS 4.3 (Medium)
Publicly Published September 4, 2023
Last Updated September 7, 2023
Researcher qilin_99

Description

The MyCryptoCheckout plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 2.125. This is due to missing nonce validation in the ~/vendor/plainview/sdk/wordpress/form2/form.php file. This makes it possible for unauthenticated attackers to perform unauthorized actions via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

References

Share

1 affected software package

Software Type Plugin
Software Slug mycryptocheckout (view on wordpress.org)
Patched? Yes
Remediation Update to version 2.126, or a newer patched version
Affected Version
  • <= 2.125
Patched Version
  • 2.126

All the threat data shared in this database is powered by Wordfence Intelligence Enterprise.
Interested in integrating this data into your platform or network?
Contact us now to discuss API access to our Wordfence Intelligence Enterprise Data Feeds.

Inquire Now

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.

Documentation