Contact Form Widget <= 1.3.9 - Sensitive Information Exposure

Information Exposure
CVE CVE-2024-34754
CVSS 5.3 (Medium)
Publicly Published May 14, 2024
Last Updated May 20, 2024
Researcher Muhammad Daffa


The Contact Form Widget – Contact Query, Contact Page, Form Maker, Query Table plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 1.3.9. This makes it possible for unauthenticated attackers to extract sensitive user or configuration data.



Vulnerability Details for Contact Form Widget – Contact Query, Contact Page, Form Maker, Query Table

Software Type Plugin
Software Slug new-contact-form-widget (view on
Patched? Yes
Remediation Update to version 1.4.0, or a newer patched version
Affected Version
  • <= 1.3.9
Patched Version
  • 1.4.0

Did you know Wordfence Intelligence provides free personal and commercial API access to our comprehensive WordPress vulnerability database, along with a free webhook integration to stay on top of the latest vulnerabilities added and updated in the database? Get started today!

Learn more

Want to get notified of the latest vulnerabilities that may affect your WordPress site?
Install Wordfence on your site today to get notified immediately if your site is affected by a vulnerability that has been added to our database.

Get Wordfence

The Wordfence Intelligence WordPress vulnerability database is completely free to access and query via API. Please review the documentation on how to access and consume the vulnerability data via API.